19th April 2021

Network issues

We are seeing various network connectivity issues on our platform and are investigating the cause.

Update 21:10: The issue seem to be related to our upstream network provider. They are currently working on resolving the issue and we will place an update a soon as we know more.

Update 21:24: The issue seem to be resolved. We are waiting on our network provider for a RCA.

We apologies for any inconvenience caused.

Update 08:43 We understand from our upstream provider that the network was hit by a cyberattack (DDoS), which was hard to mitigate.